はじめに
前のページ
次のページ

実行中アプリケーションの表示名を自由に設定『タイとる君』 V2.4

2010/04/04 沌珍館企画

    『タイとる君』はタスクバーやタイトルバーに表示される実行中アプリケーションの名前を一時的に編集設定できるツールです。プログラム名表記などの先頭文字列を自動的に削除する指定も可能です。
  対象アプリのタイトルだけでなく、画面内の文字列やタイトルバー右端の閉じる[×]などのフォームボタンの有効無効化も操作できます。対象ウィンドウの最小化・最大化や、「常に手前に表示」の設定・解除も可能です。
  一覧画面からの選択だけでなく、マウスドラッグで対象文字列を取得してくることもできます。対象がエディットボックスの場合には、中身の文字列も取得可能です。パスワード状態でも解除して取得します。
  以下のような場面にお勧めです。

  • エディタなどのタスクバーには、プログラム名よりもファイル名を表示してほしい
  • エクスプローラをフルパス表示で複数起動すると、タスクバー上の表示はドライブ名から始まって区別が付かないので、一番下のフォルダ名を表示させたい
  • 誤解されそうな名前がタスクバーに出ているので、なんとかしたい
  • 時間のかかる処理なので、いつ起動したかタイトルバーに残しておきたい
  • タイトルバーの文字列をクリップボードにコピーしたい
  • 画面内のボタンやラベルの文字列を一時的に変更したい
  • タイトルバー右端の最小化[＿]、最大化[□]、閉じる[×]などのボタンを個別に無効化・有効化したい
  • 最小化ボタンのないアプリを最小化しておきたい
  • エクスプローラなど特定のアプリを常に手前に表示させておきたい
  • 「常に手前に表示」に設定されているアプリを後ろにまわしたい
  • とにかく、いろいろやってみたい(^-^)//

前のページ
次のページ
上に戻る

最終更新：2010年4月4日 (C)沌珍館企画,2005-2010


準備

【準備】

（インストールするには）

  • 必ずインストーラを使ってインストールしてください。
  • 旧版をアンインストールしておく必要はありません。（上書きインストール可）
  • ただし旧形式のヘルプやインストーラが残ることがあるため、なるべく事前の旧版アンインストールをお勧めします。
  • レジストリはアンインストールのためだけに使います。
  • インストール後は自動的に起動します。ＰＣを再起動する必要はありません。

（アンインストールするには）

  • 必ずコントロールパネルの「プログラムと機能」（Windows7の場合）、「プログラムの追加と削除」(WindowsXPの場合)、「アプリケーションの追加と削除」(Windows2000の場合)を使ってアンインストールしてください。
  • レジストリからも削除されます。


基本　簡単です

【使い方】

（基本）　簡単です

  • 起動すると、他のアプリケーションの名前の一覧を表示します。
  • 変更したい名前を選択すると、右側に設定の候補が表示されます。
  • 候補一覧から選択するか、右下の入力域に直接入力してください。
  • 「反映」ボタンを押せば、画面上の表示に反映されます。
  • 候補一覧からダブルクリックで選択しても、即反映されます。
  • 「オプション」画面での設定は画面内の説明とおりです。


応用１　一覧画面から

【使い方】

（応用１）　一覧画面から出来ること

  • アプリケーション一覧リストから対象アプリケーションをダブルクリックすれば、画面をそのまま最前面に表示できます。
  • 右クリックからのメニュー選択で、選択したタイトル文字列やタイトル文字列一覧をクリップボードにコピーできます。
  • タイトルバーの文字列とタスクボタンの文字列を別々に管理しているアプリケーションでは、それぞれ別個の文字列に編集することができます。
  • 任意の文字列を設定候補の一覧に追加するよう事前に設定しておくことができます。
  • 対象アプリケーションのウィンドウサイズを、最小化・最大化したり、元の大きさに戻すことができます。
  • 対象アプリケーションのウィンドウを、常に手前に表示に設定したり、設定を解除したりできます。

（注意）

  • 画面上の表示を一時的に変更しているだけなので、文字列は保存されません。（相手のアプリケーションが常駐している間は保持されます）
  • 自分のタイトルを書き換えるなど、対象アプリケーション側から積極的に文字列を変更してくる場合には無力です。
  • 「常に手前に表示」の設定や解除は、対象アプリケーションの構造や開発言語によって、かならずしも期待した通りにはならないことが判っています。ご了承ください。


応用２　画面内文字列

【使い方】

（応用２）　画面内文字列も取得・編集・反映できます

  • 左側のアプリケーション一覧上での右クリックメニュー選択（「ウィンドウ内の文字列を抽出」）で、対象ウィンドウ内からさらに文字列を抽出して編集することができます。
  • ボタン名やラベル文字列、ダイアログ内の文字列などが編集できます。 英語版アプリの一時的な日本語化などにご利用下さい。
  • 「反映」ボタンで反映されます。ただし、以下の（注意）をご参照ください。
  • 「最新の状態に更新」ボタンで、アプリケーション一覧表示に戻ります。

（注意）

  • 他アプリケーション内の文字列書換えは、対象アプリの構造や開発言語等によって以下のように結果が様々であることが判っています。ご了承ください。
    1. その場で即反映される
    2. 一度最小化して戻すと反映される
    3. 他ウィンドウで一度覆ってから再描画させると反映される
    4. 何をしても反映されない
    5. そもそも抽出されない
  • タイトルバーやタスクバーの文字列と同じく、画面上の文字列を一時的に編集しているだけなので、変更は保存されません。
  • 「タイとる君」による各種の書換えは、個人利用の範囲内限定でお願いします。それを超えて使用すると対象アプリ開発元への著作権侵害、利用規約違反、名誉毀損等となる場合がありますのでご注意下さい。


応用３　マウスドラッグ

【使い方】

（応用３）　マウスドラッグでも文字列取得できます

  • フォーム上の反応する場所でマウスの左ボタンを押したままにすると、マウスカーソルが「？」付きのヘルプ状態になります。
  • そのまま（左ボタンを押したまま）、マウスを対象アプリケーションのタイトルバーや、ボタン、ラベルなどの文字列の上に持って行き、そこで左ボタンを離すと、その場所の文字列が取得できます。
  • 文字列を編集して、その位置に反映させることができます。
  • エディットボックスを指定すると、中身の文字列が取得できます。パスワード状態（****等）の場合には解除してから取得します。

（注意）

  • 対象アプリケーションの構造や開発言語によって、かならずしも文字列の取得や反映ができるとは限りません。 いろいろな場合があるのは（応用２）の注意事項と同じです。
  • ブラウザの内側は別世界ですので、ほとんどの場合、期待通りには機能しません。


応用４　自動脱帽指定

【使い方】

（応用４）　自動的に定型文字列を削除して編集することができます

  • タイトルバー文字列に対する左側（先頭）削除の部分文字列を指定しておくことができます。
  • 「Microsoft Excel - 」を左側削除（脱帽）文字列として指定しておけば、「Microsoft Excel - 沌珍館.xls」というタイトルバー文字列は自動的に「沌珍館.xls」だけになります。
  • オプション設定画面で有効化しておけば、起動順序は対象アプリケーションが先でも、「タイとる君」が先でもどちらでも機能します。
  • 指定文字列での左側削除は、大文字小文字は区別せずにマッチングします。

（注意）

  • システム的な負荷は高くなりますので、一覧画面などの表示がちらつきやすくなります。状況に応じてご利用ください。
  • 左側削除文字列は、必要最小限の長さと個数で指定されることをお勧めします。
  • 初期状態では、「Microsoft Excel - 」「Microsoft Word - 」「Microsoft PowerPoint - 」の３つが設定されていますが、サンプルなので他意はありません。
  • 特にWordはエディションによってタイトル表示形態が変わっているので（前後が逆とか）、ご利用環境に合わせて編集してご利用ください。


応用５　タイトルバーボタン

【使い方】

（応用５）　タイトルバーのシステムボタンを制御できます

  • 右クリックからのメニュー選択で、相手のアプリケーションのタイトルバー右端の最小化[＿]、最大化[□]、閉じる[×]などのボタンを個別に無効化・有効化することができます。
  • 対象のアプリケーションを、「画面を出さずに使いたいのに、最小化できない（閉じるしかない）」「大きくして使いたいのに、最大化できない」などの場合に、相手の最小化・最大化ボタンを使えるようにできます。
  • また、対象のアプリケーションを、「うっかり終了させないように、閉じるボタンを押せなくしたい」という場合などに、相手の閉じるボタンを無効化できます。もちろん、有効に戻すこともできます。

（注意）

  • 「最小化」ボタンと「最大化」ボタンを一緒に無効にすると、両方とも表示されなくなります。これはWindows側の仕様です。
  • 「開く(&O)」等のWindows標準ダイアログや、「タスクマネージャ」等のシステム系ツールなどでは、ボタン設定を反映できない（押せても効かない、マウスドラッグでもサイズ変更できない）ものがあります。


よくあるご質問

【よくあるご質問】

１．「XPで動いていたのに、Vistaにしたら動かなくなったのですが」 (2009/09)

  • 一旦アンインストールしてから、最新版の「タイとる君」を再度インストールして下さい。
  • 理由はたぶん環境により様々だと思いますが、最新版のインストールで動くようになった、というご報告がほとんどです。
  • 開発元に環境がないので、Vistaは未確認という扱いになっているだけです。


改版履歴

【改版履歴】

V1.0 : 2005/10/10

  • WindowsXP, Turbo Delphi 2006 Explorerで新規作成。
  • とりあえず思い通りの動きをするところまで到達。
  • こんなことが出来たのかというのが正直な感想。

V1.1 : 2005/11/11

  • デザインと使い勝手を整備して一般公開できるレベルにした。

V1.2 : 2005/12/20

  • 最小化時にはタスクバーではなくタスクトレイに行くようにした。
  • 設定候補文字列のダブルクリックでも即反映するようにした。
  • 設定非対象にする自分自身の認識方法を改善した。
  • 安全のため多重起動できないようにした。

V1.3 : 2006/04/03

  • 「タイトル一覧」や「設定候補の一覧」の文字列を、右クリックでクリップボードにコピーできるようにした。

V1.4 : 2006/05/04

  • 「自動更新」モードに設定できるようにした。
  • 「自動更新」モードでなくても、アイコン状態から戻るときには必ず最新状態に更新するようにした。
  • URL形式でファイル名を表示しているブラウザがいる場合には、ファイル名を切出して設定候補の一覧に追加するようにした。

V1.5 : 2006/06/05

  • アプリケーション一覧のダブルクリック、または右クリックメニューで直接対象画面を表示できるようにした。
  • 「自動更新」モードをデフォルト設定にした。
  • 二重起動阻止のメッセージ後に、既存プロセスを表示するようにした。
  • 文字列入力後のエンターキーでも設定反映させるようにした。
  • 状態制御を整備して非活性域は操作できないようにした。

V1.6 : 2007/05/04

  • 全角空白も表記区切りと見なして候補文字列を作るようにした。
  • 自力で書いていたタスクトレイ処理をTTrayIconコンポーネントで置き換えた。
  • 自力で書いていたリサイズ時のレイアウト処理をTGridPanelコンポーネントで置き換えた。
  • 二重起動阻止後に最前面に出す既存プロセスの検出方法を改善した。
  • ヘルプをHtmlヘルプにした。

V1.7 : 2008/04/17

  • 設定候補の一覧に任意のプリセット文字列を追加できるようにした。
  • ボタン名の「設定」を、より判りやすく「反映」に改善した。
  • バージョン表示ダイアログをグラデーション表示で自作した。
  • 最大化状態を終了時に保持しておけるようにした。
  • リサイズした状態で終了すると次回起動時に表示が乱れることがあるのを修正。

V1.8 : 2008/10/12

  • タイトルバー文字列とタスクボタン文字列を別々に管理しているアプリケーションにも対応した。
  • 子ウィンドウやダイアログなどの文字列も編集できるようにした。

V1.9 : 2009/01/09

  • 対象アプリケーション画面内のボタン名、ラベル文字列なども変更できるようにした。

V2.0 : 2009/05/20

  • 対象アプリケーションのタイトルバー右端の最小化[＿]、最大化[□]、閉じる[×]などのボタンを個別に無効化・有効化できるようにした。
  • 自分自身の最小化ボタンを追加した。
  • 内部のリスト処理を見直して効率化した。
  • リサイズ時のレイアウト保持をGridPanelだけでできるようにした。

V2.1 : 2009/08/21

  • タイトルバー文字列の左側削除（脱帽）を設定できるようにした。
  • 自分自身の終了ボタンを無効にできるようにした。

V2.2 : 2009/09/22

  • マウスの左ボタンドラッグで対象アプリの文字列を取得できるようにした。
  • 対象がエディットボックスの場合には中身のテキストも取得できるようにした。
  • エディットボックスがパスワード状態でも解除して取得できるようにした。

V2.3 : 2010/02/23

  • 開発環境をWindows7に更新。
  • 内部処理を改善して反応速度と表示速度を向上させた。
  • 「アプリケーションのタイトル一覧」「設定候補の一覧」の横スクロールバーは、必要時に必要な長さで動的に表示するようにした。
  • 常に前面に表示しておく設定ができるようにした。
  • バージョン表示ダイアログに自分の起動パスを表示するようにした。
  • マウスドラッグでの文字列取得がグレーアウトエリアでも出来てしまうのを修正。

V2.4 : 2010/04/04

  • 右クリックからタイトル文字列の一覧をコピーできるようにした。
  • 「ウィンドウ内の文字列を抽出」の際の表示を改善した。
    1. リストボックスの表題を「ウィンドウ内の文字列一覧」にした。
    2. 復帰ボタンの表題を「アプリケーションの一覧に戻る」にした。
    3. 選択するまで「設定候補の一覧」「設定する文字列」を表示しないようにした。
  • 対象アプリケーションのウィンドウサイズを制御できるようにした。
    1. 対象のウィンドウを最小化できるようにした。
    2. 対象のウィンドウを最大化できるようにした。
    3. 最小化、最大化されているウィンドウを元のサイズに戻せるようにした。
  • 対象アプリケーションのウィンドウの重なりを制御できるようにした。
    1. 対象のウィンドウを手前に表示できるようにした。
    2. 対象のウィンドウを「常に手前に表示」に設定できるようにした。
    3. 対象のウィンドウの「常に手前に表示」設定を解除できるようにした。


関連情報

【関連情報】

このプログラムは以下の環境で作成されています。

  • Borland Turbo Delphi 2006 Explorer
  • Microsoft Windows7 Home Premium
  • Fujitsu FMV-BIBLO MG50LN
  • SpeedHelpPad 1.24.0.0 （textex氏）
  • EXEpressCX Version 5.20 （web technology Corp.）

動作確認済： Windows2000, WindowsXP, Windows7
動作未確認： Windows95, Windows98, WindowsNT, WindowsVista
設計対象外： Windows3.1, WindowsCE, WindowsMobile

  このプログラムはフリーウェアです。内容を改変しないかぎり、自由に再配布してかまいません。ただしこのプログラムを使用した（あるいは使用できなかった）ことによるいかなる損害に対しても開発元は責任を負えませんのでご了承下さい。

All Rights Reserved, CopyRight(C)2005-2010
info@tonchinkan.office.ne.jp 沌珍館企画
http://hp.vector.co.jp/authors/VA012191/
http://maglog.jp/tonchinkan/